Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

3G Mode unusable

#1

My phone show no network bars / signals when I switch to 3G mode only which make it unavailable but wen I switch to 3G and 2G mode and search for network manually.. It detects 3G and I browse with it for few minutes before going back to 2G .
I also noticed an area in my street, immediately I reached there, the 3G network will be constant for browsing wen put or remains in 3G and 2G mode, but on putting it back to 3G only, it won't show d signal. Pls help. MTN [email protected] S620i



Attached Files
.png   Screenshot_2015-09-15-07-01-42.png (Size: 25.19 KB / Downloads: 1)
Reply
#2
(09-16-2015, 04:13 AM)Tejrooney Wrote: My phone show no network bars / signals when I switch to 3G mode only which make it unavailable but wen I switch to 3G and 2G mode and search for network manually.. It detects 3G and I browse with it for few minutes before going back to 2G .
I also noticed an area in my street, immediately I reached there, the 3G network will be constant for browsing wen put or remains in 3G and 2G mode, but on putting it back to 3G only, it won't show d signal. Pls help. MTN [email protected] S620i

the signal strength is not steady in your area then.
you should avoid setting your phone to 3G only in an area with varying signal strength. 3G and 2G mode will select the best available network so when there's no 3G, it'll fall back on 2G.
in some cases, setting to 3G only even in an area with strong 3G network will result in no signal. might be an issue with the ROM or the 3G IC
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
I bought d phone last year, it was working properly as normal and got spoiled. MTN later fixed d phone but didn't unscrew it cause the seal is still intact on the bolt. And I think it must av undergo a ROM changing... So since then I av been witnessing this issue(as said: initially, it wasn't like that wen I newly bought the phone)... I receives 3G services as normal it ought to be( in fact am posting this message with 3G services on~ check d attachment) so am satisfied. But wen I change the mode to 3G only, the network signal goes off... 3G services is available both on my sim and phone but that I don't understand.
Reply
#4
Attachment

Attached Files
.png   Screenshot_2015-09-16-12-11-29.png (Size: 42.8 KB / Downloads: 2)
Reply
#5
(09-16-2015, 12:12 PM)Tejrooney Wrote: I bought d phone last year, it was working properly as normal and got spoiled. MTN later fixed d phone but didn't unscrew it cause the seal is still intact on the bolt. And I think it must av undergo a ROM changing... So since then I av been witnessing this issue(as said: initially, it wasn't like that wen I newly bought the phone)... I receives 3G services as normal it ought to be( in fact am posting this message with 3G services on~ check d attachment) so am satisfied. But wen I change the mode to 3G only, the network signal goes off... 3G services is available both on my sim and phone but that I don't understand.

well, since your 3G works fine in 3G and 2G mode then its nothing to worry about right?
probably just a minor ROM bug when in 3G only mode.
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#6
Normal but most of the time I search for network manually to obtain the 3G network. Becoming too annoying
Reply
#7
(09-17-2015, 12:17 AM)Tejrooney Wrote: Normal but most of the time I search for network manually to obtain the 3G network. Becoming too annoying

have you tried re-flashing the stock ROM or the NVRAM backup from another phone of the same model?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply










Users browsing this thread:
1 Guest(s)