Hi, Guest! Login / Register




Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tutorial] How to fix an MTK Android phone that wont come on after interrupting SP Flash tool


(03-16-2017, 07:13 AM)Moosa89 Wrote: Hi hovatek. I was trying to root my infinix hot 4 x557 with sp flash tools and i interrupted it because there was no activity on the tools since 15mins. After that the phone didnt came alive. I followed your tutorial and tried charging it for 3 full days via wall charger and tried seeing it every once in a while by pressing the power button if my phone is alive again or not. However, there's no progress up till date. I dont want to open the battery and void the warranty. Should I wait for a longer period and keep it to charge or is there any other solution too? Kindly reply asap.

You'll just have to keep charging then, it'll eventually show a sign of life.
You could sometimes try holding the power button while connected to charger. The charging process tends to take longer but does work


Reply
Thanks hovatek. After it comes to life, do I have to flash it or leave it as it is? I was actually trying to root it by flashing recovery, but didn't let complete. Do I have to flash the whole firmware again or use the phone as it is when it comes back to life?
Reply
(03-17-2017, 09:28 PM)Moosa89 Wrote: Thanks hovatek. After it comes to life, do I have to flash it or leave it as it is? I was actually trying to root it by flashing recovery, but didn't let complete. Do I have to flash the whole firmware again or use the phone as it is when it comes back to life?

Since flashing didn't complete, you shouldn't need to flash the entire firmware. Just use the phone as is
Reply
Thanks a tonne hovatek. Let me know how I can buy you a beer. Cheers Smile

(03-16-2017, 02:12 PM)hovatek Wrote:
(03-16-2017, 07:13 AM)Moosa89 Wrote: Hi hovatek. I was trying to root my infinix hot 4 x557 with sp flash tools and i interrupted it because there was no activity on the tools since 15mins. After that the phone didnt came alive. I followed your tutorial and tried charging it for 3 full days via wall charger and tried seeing it every once in a while by pressing the power button if my phone is alive again or not. However, there's no progress up till date. I dont want to open the battery and void the warranty. Should I wait for a longer period and keep it to charge or is there any other solution too? Kindly reply asap.

You'll just have to keep charging then, it'll eventually show a sign of life.
You could sometimes try holding the power button while connected to charger. The charging process tends to take longer but does work

(03-18-2017, 09:44 AM)hovatek Wrote:
(03-17-2017, 09:28 PM)Moosa89 Wrote: Thanks hovatek. After it comes to life, do I have to flash it or leave it as it is? I was actually trying to root it by flashing recovery, but didn't let complete. Do I have to flash the whole firmware again or use the phone as it is when it comes back to life?

Since flashing didn't complete, you shouldn't need to flash the entire firmware. Just use the phone as is
Reply
(This post was last modified: 03-18-2017, 04:39 PM by hovatek. )
(03-18-2017, 11:10 AM)Moosa89 Wrote: Thanks a tonne hovatek. Let me know how I can buy you a beer. Cheers Smile

You're welcome.
You can buy me a beer simply by telling your friends about Hovatek Forum. That equates to about 5 crates of beer in my books (LOL)
Reply
Hello hovatek, I have Lenovo a5000 and the phone keeps getting lenovo logo when i restarted it so i tried to flash a new stock kitkat rom using SP Flashtool, and it was my first time to do this process, and flashing starts but unforunately, usb cable disconnected at 52% by wrong, since then my phone isn't opening nor charging or any thing except when I connect it to PC it makes sound it gives me in the device manager Under universal Serial Bus controllers section: Unknown USB Device ( Device Descriptor Request Failed),
And gives me in the Task bar a USB icon saying: USB device isn't recognized. The last USB device you connected to this computer malfunctioned, and windows does not recognize it.
I followed this thread and left the phone to Charge about one day as well as manual install of drivers but I didn't remove the battery because it is a built in battery but nothing happens...
So please what should i do now because i'm getting nervous about the phone Since then.
Thanks in advance!
Reply
(04-01-2017, 05:50 PM)ahmedmsaeed95 Wrote: Hello hovatek, I have Lenovo a5000 and the phone keeps getting lenovo logo when i restarted it so i tried to flash a new stock kitkat rom using SP Flashtool, and it was my first time to do this process, and flashing starts but unforunately, usb cable disconnected at 52% by wrong, since then my phone isn't opening nor charging or any thing except when I connect it to PC it makes sound it gives me in the device manager Under universal Serial Bus controllers section: Unknown USB Device ( Device Descriptor Request Failed),
And gives me in the Task bar a USB icon saying: USB device isn't recognized. The last USB device you connected to this computer malfunctioned, and windows does not recognize it.
I followed this thread and left the phone to Charge about one day as well as manual install of drivers but I didn't remove the battery because it is a built in battery but nothing happens...
So please what should i do now because i'm getting nervous about the phone Since then.
Thanks in advance!

For USB not recognized, taking out the battery (even though its inbuilt) is about the fastest fix. If you don't want to do this then you'll need to keep charging. This is slower but does work
Reply
Dear Hovatek,

Thank you extremely for posting this information. I had this problem and I left my Tablet (HP 10 G2) charging for a couple of hours a few days ago after accidentally interrupting the readback and nothing was working so I ended up just leaving aside. Strangely enough it seems as tho the battery drained on its own while sitting there because when I read a couple of pages about others who needed several days for it to work, I plugged mine back in to give it another shot and surprisingly the low battery indicator appeared on the screen. So I think everything will be alright once it's charged. However I don't think the tablet is using the right drivers because even after installing the MediaTek USB VCOM drivers and following all of the steps that you gave, I still was having issues. But I'll post the details and everything about my trouble under that particular thread later on sometime. Thanks again, and to everyone who posted about sometimes having to wait days!!!
Reply
(04-01-2017, 05:50 PM)ahmedmsaeed95 Wrote: Hello hovatek, I have Lenovo a5000 and the phone keeps getting lenovo logo when i restarted it so i tried to flash a new stock kitkat rom using SP Flashtool, and it was my first time to do this process, and flashing starts but unforunately, usb cable disconnected at 52% by wrong, since then my phone isn't opening nor charging or any thing except when I connect it to PC it makes sound it gives me in the device manager Under universal Serial Bus controllers section: Unknown USB Device ( Device Descriptor Request Failed),
And gives me in the Task bar a USB icon saying: USB device isn't recognized. The last USB device you connected to this computer malfunctioned, and windows does not recognize it.
I followed this thread and left the phone to Charge about one day as well as manual install of drivers but I didn't remove the battery because it is a built in battery but nothing happens...
So please what should i do now because i'm getting nervous about the phone Since then.
Thanks in advance!

Hi we have the same problem, did your phone show signs of life now? bcause im charging my phone for 2 days now and still no signs of life
Reply
(05-28-2017, 03:08 PM)jctheLion Wrote: Hi we have the same problem, did your phone show signs of life now? bcause im charging my phone for 2 days now and still no signs of life

Please, create a new thread so we focus on it
see https://forum.hovatek.com/thread-514.html for how to create a thread
Reply










Users browsing this thread:
1 Guest(s)