Hi, Guest! Login / Register




Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Tutorial] How to fix an MTK Android phone that wont come on after interrupting SP Flash tool

#51

I've an BQ Aquaris E5 FHD (MTK6592) and today I decided to update to latest firmware version via hard reset using SP Flash Tool, the first time the process was interrupted without reason, so I tried for second time and everything was OK, the phone was able to boot normally. Then I noticed that the serial number was wrong (0123456789ABCDEF) so I powered off the phone and wanted to correct it using IMEI Sn Writer, but for some reason it couldn't connect to the phone, so I disconnected the cable and the phone was not able to boot anymore. The phone seemed bricked, every time I connected it to Windows appeared as "MTK Usb Com (COMx)". I think it had corrupted preloader so I spent hours and hours reading forums and trying to flash preloader with SP Flash Tool without luck. I had read this topic so the last try was leaving it charging and voila! after 1 or 2 hours it booted and showed the battery charging animation with 50% of battery, then I disconnected the cable and connected again and it started charging from empty (0%). I suspect this is because some battery calibration data is lost after unsuccessful flashing, it's strange.


Reply
#52
(02-13-2016, 05:49 AM)aaron89 Wrote: I've an BQ Aquaris E5 FHD (MTK6592) and today I decided to update to latest firmware version via hard reset using SP Flash Tool, the first time the process was interrupted without reason, so I tried for second time and everything was OK, the phone was able to boot normally. Then I noticed that the serial number was wrong (0123456789ABCDEF) so I powered off the phone and wanted to correct it using IMEI Sn Writer, but for some reason it couldn't connect to the phone, so I disconnected the cable and the phone was not able to boot anymore. The phone seemed bricked, every time I connected it to Windows appeared as "MTK Usb Com (COMx)". I think it had corrupted preloader so I spent hours and hours reading forums and trying to flash preloader with SP Flash Tool without luck. I had read this topic so the last try was leaving it charging and voila! after 1 or 2 hours it booted and showed the battery charging animation with 50% of battery, then I disconnected the cable and connected again and it started charging from empty (0%). I suspect this is because some battery calibration data is lost after unsuccessful flashing, it's strange.
Have you been charging since you saw 0%?
Reply
#53
Please I opened a thread earlier..... My tecno p5 is still dead. It does not vibrate or come up.. Please help me
Reply
#54
(02-13-2016, 10:35 AM)matybazz Wrote:
(02-13-2016, 05:49 AM)aaron89 Wrote: I've an BQ Aquaris E5 FHD (MTK6592) and today I decided to update to latest firmware version via hard reset using SP Flash Tool, the first time the process was interrupted without reason, so I tried for second time and everything was OK, the phone was able to boot normally. Then I noticed that the serial number was wrong (0123456789ABCDEF) so I powered off the phone and wanted to correct it using IMEI Sn Writer, but for some reason it couldn't connect to the phone, so I disconnected the cable and the phone was not able to boot anymore. The phone seemed bricked, every time I connected it to Windows appeared as "MTK Usb Com (COMx)". I think it had corrupted preloader so I spent hours and hours reading forums and trying to flash preloader with SP Flash Tool without luck. I had read this topic so the last try was leaving it charging and voila! after 1 or 2 hours it booted and showed the battery charging animation with 50% of battery, then I disconnected the cable and connected again and it started charging from empty (0%). I suspect this is because some battery calibration data is lost after unsuccessful flashing, it's strange.
Have you been charging since you saw 0%?

I left it about an hour connected to PC with SP Flash Tool running in download mode with only preloader selected, then suddenly I noticed that the phone got disconnected from PC and the application showed flashing error, so I tried to disconnect and connect the cable but the phone was no longer detected in PC, I was scared that the brick got worse but then I connected to wall charger and booted to the charging animation, I waited until it reached 50% and re-flashed the whole firmware again and since then phone is fine Big Grin
Reply
#55
(02-13-2016, 07:08 PM)aaron89 Wrote:
(02-13-2016, 10:35 AM)matybazz Wrote:
(02-13-2016, 05:49 AM)aaron89 Wrote: I've an BQ Aquaris E5 FHD (MTK6592) and today I decided to update to latest firmware version via hard reset using SP Flash Tool, the first time the process was interrupted without reason, so I tried for second time and everything was OK, the phone was able to boot normally. Then I noticed that the serial number was wrong (0123456789ABCDEF) so I powered off the phone and wanted to correct it using IMEI Sn Writer, but for some reason it couldn't connect to the phone, so I disconnected the cable and the phone was not able to boot anymore. The phone seemed bricked, every time I connected it to Windows appeared as "MTK Usb Com (COMx)". I think it had corrupted preloader so I spent hours and hours reading forums and trying to flash preloader with SP Flash Tool without luck. I had read this topic so the last try was leaving it charging and voila! after 1 or 2 hours it booted and showed the battery charging animation with 50% of battery, then I disconnected the cable and connected again and it started charging from empty (0%). I suspect this is because some battery calibration data is lost after unsuccessful flashing, it's strange.
Have you been charging since you saw 0%?

I left it about an hour connected to PC with SP Flash Tool running in download mode with only preloader selected, then suddenly I noticed that the phone got disconnected from PC and the application showed flashing error, so I tried to disconnect and connect the cable but the phone was no longer detected in PC, I was scared that the brick got worse but then I connected to wall charger and booted to the charging animation, I waited until it reached 50% and re-flashed the whole firmware again and since then phone is fine Big Grin
Ok good to hear
Enjoy

Reply
#56
(11-06-2014, 02:48 PM)hovatek Wrote: This guide is for MTK devices like Tecno, Gionee, Micromax, Infinix, Opsson, etc

If you dont know how to flash files using SP flash tool, follow this guide @ http://forum.hovatek.com/thread-159.html


If you wish to do a read back / ROM dump using Sp flash tool, follow this guide @ http://forum.hovatek.com/thread-526.html


What you should know about SP flash tool is that you shouldn't interrupt a flash or read back process. If you do, the phone will go off and not come on at all. You might get the "USB device not recognized" error on further flashing attempts. If somehow, the process got interrupted and you now have a totally dead phone on your hands, don't panic. All you need to do is connect the phone to a computer (via a USB cord) or power source and leave it to charge for some time. It could take up to two hours but once the phone is revived, your battery could read as low as 1% . just leave it to keep charging before powering it up. 


Tips to speed things up

* Remove the battery > Connect the phone to a charger without battery inside > Slot in the battery while the phone is still connected to the charger 
* You could keep pressing the Volume up + Power button while charging
* You could remove and boost the battery using a desktop / external charger then resume internal charging.
* Uninstall then re-install MTK preloader vcom drivers using this guide @ https://forum.hovatek.com/thread-440.html

Heyy Plzz help me I have by mistakely started flashing my Xolo 8x 1000 using another rom but then red bar stopped at 100% and flashing ont start after that
but then after that my android is not getting detect
and I tried to uninstall and install drivers and also different sp flashtools and also on windows 10, 7, xp
but then same problem pc is detecting as a vcom driver on control panel bt sp flashtool in any of the pc is not detcting plzz help me
Reply
#57
(11-06-2014, 02:48 PM)hovatek Wrote: This guide is for MTK devices like Tecno, Gionee, Micromax, Infinix, Opsson, etc

If you dont know how to flash files using SP flash tool, follow this guide @ http://forum.hovatek.com/thread-159.html


If you wish to do a read back / ROM dump using Sp flash tool, follow this guide @ http://forum.hovatek.com/thread-526.html


What you should know about SP flash tool is that you shouldn't interrupt a flash or read back process. If you do, the phone will go off and not come on at all. You might get the "USB device not recognized" error on further flashing attempts. If somehow, the process got interrupted and you now have a totally dead phone on your hands, don't panic. All you need to do is connect the phone to a computer (via a USB cord) or power source and leave it to charge for some time. It could take up to two hours but once the phone is revived, your battery could read as low as 1% . just leave it to keep charging before powering it up. 


Tips to speed things up

* Remove the battery > Connect the phone to a charger without battery inside > Slot in the battery while the phone is still connected to the charger 
* You could keep pressing the Volume up + Power button while charging
* You could remove and boost the battery using a desktop / external charger then resume internal charging.
* Uninstall then re-install MTK preloader vcom drivers using this guide @ https://forum.hovatek.com/thread-440.html

heyy admin... Even I am in the same problem .. even I was trying to flash a stock rom on my Xol 8x 1000 and bymistake i selected the wrong scatter file whereas the flashing procedure started and red bar cam to 100% then again then went white @ 0% then it stuck obviously it was a wrong rom so i disconnected to select the correct one but then after that my phone is showing up vcom download DA port something in Device Manager and not detecting in SP FT so wat u suggest me to do
Reply
#58
(03-03-2016, 09:02 PM)swathijangam Wrote: Heyy Plzz help me I have by mistakely started flashing my Xolo 8x 1000 using another rom but then red bar stopped at 100% and flashing ont start after that
but then after that my android is not getting detect
and I tried to uninstall and install drivers and also different sp flashtools and also on windows 10, 7, xp
but then same problem pc is detecting as a vcom driver on control panel bt sp flashtool in any of the pc is not detcting plzz help me

As the guide instructs, you either keep charging till it comes on or you take out the battery and reinsert
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#59
(This post was last modified: 03-23-2016, 10:31 AM by dev666. )
It was at 7pm when I was flashing my friend's bootlooping HTC Desire 820s when I realized that I was accidentally flashing my backed up userdata partition of about 9gb to his phone too.
I said to myself: "This is going to waste me a lot of my time".
I grew more impatient.
It was at 40% by the 10th minute of flashing when I decided to click on the STOP button on SP Flash Tool so that I could flash the smaller factory userdata partition but I was in for a big SCARE.
When I tried to flash the phone again, SP Flash Tool could not begin flashing, I could hear the connection and disconnection sound though.
I tried to switch on the phone, it could not. I tried rebooting into bootloader mode, the phone stayed off. I thought it was just a corrupt bootloader which SP Flash Tool can easily handle while holding all buttons together...
Still SP Flash Tool could not begin flashing. On device manager the phone was recognized as USB VCOM PORT only.
Then I thought maybe it's a drivers problem, to rule that out, I tested flashing cache partition only on my own phone of the same model. It worked..
So a drivers issue was unlikely.
It looked grim.
My friend had left me with the phone about an hour earlier and left for a date with his GF.. The flash would have been done by now had I not interrupted it..
I then came across this thread, I thought why not give it a try? Kept the phone on charger for one hour, charging light was off.
The third hour, I tried flashing it, unsuccessful.
My friend was back.. I had to lie to him that his phone ran out of power so I had to charge it to full power first before the PC could recognize it, he gladly agreed.
12:30 am SP Flash Tool could still not begin flashing, I went to sleep and left the phone on the wall charger.
3 am I suddenly woke up to check on the phone and guess what!! the charging light was blinking, at about 3 seconds intervals.
I hastily disconnected the phone from the charger and switched on my PC and tried to flash it and to my amazement Preloader drivers installed and SP Flash Tool could flash the entire firmware and the phone successfully switched on, battery was at 1%.
From that day, I vowed never to interrupt a flash or a readback with SP Flash Tool as I ended up wasting 8 hours when I thought I would waste 30-35 minutes.
I also advice all the others never to give up when caught in this situation, even for a non removable battery phone like mine, just keep on charging it and in the and the phone will show signs of life and will be flashable.
Thank you very much HovaTek
Reply
#60
Hey...Admin i am using micromax canvas 2 colors,while i was flashing i accidently intrreupt it and the phone was dead. As you have directed i kept it for charging..Its been 2 days but the phone is not switching on.. what to do i'm nervous..plz respond
Reply










Users browsing this thread:
2 Guest(s)