Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

tecno phone problem

#1

good evening, i use a tecno p9 pls i tried joining my charger to anoder charger to make my charger longer and connnected it wrongly.. I mistakenly connected the positive to negative and negative to positive and i put it in the electric socket for about five seconds before removing cuz i was smelling something burning from the fone... Now when i try charging it with a normal charger it does not show any sign of charging and its not comin up. Pls help.


Reply
#2
(10-14-2015, 12:42 PM)bolarge717 Wrote: good evening, i use a tecno p9 pls i tried joining my  charger to anoder  charger  to make my charger longer and connnected it wrongly.. I mistakenly connected the positive to negative and negative to positive and i put it in the electric socket for  about five seconds before removing cuz i was smelling something burning from the fone... Now when i try charging it with a normal charger it does not show any sign of charging and its not comin up. Pls help.

You need to have the board looked at
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(10-14-2015, 03:09 PM)hovatek Wrote:
(10-14-2015, 12:42 PM)bolarge717 Wrote: good evening, i use a tecno p9 pls i tried joining my  charger to anoder  charger  to make my charger longer and connnected it wrongly.. I mistakenly connected the positive to negative and negative to positive and i put it in the electric socket for  about five seconds before removing cuz i was smelling something burning from the fone... Now when i try charging it with a normal charger it does not show any sign of charging and its not comin up. Pls help.

You need to have the board looked at

thanks
Reply










Users browsing this thread:
1 Guest(s)