Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] bricked infinix x551

#11

I installed all the drivers for mtk devices ( I will upload them soon) so I couldn't tell which one was my phone because it was connecting and disconnecting after two seconds...luckily sp flash tools recognized the device through DA USB VCOM port where I tried to flash bt there was an error. I was directed to format the phone on the other thread which I did, and then I flashed the KitKat ROM then finally did the upgrade to Lollipop.. However after the upgrade the phone registered an invalid IMEI and following the tutorial I used the Mobile Uncle app to set new IMEI values then rebooted and the phone was as good as new


Reply
#12
(This post was last modified: 10-26-2015, 09:36 PM by hovatek. )
(10-26-2015, 02:39 PM)tsozungu Wrote: I installed all the drivers for mtk devices ( I will upload them soon) so I couldn't tell which one was my phone because it was connecting and disconnecting after two seconds...luckily sp  flash tools recognized the device through DA USB VCOM port where I tried to flash bt there was an error. I was directed to format the phone on the other thread which I did, and then I flashed the KitKat ROM then finally did the upgrade to Lollipop.. However after the upgrade the phone registered an invalid IMEI and following the tutorial I used the Mobile Uncle app to set new IMEI values then rebooted and the phone was as good as new

The fixes to all SP flash tool errors are listed @ https://forum.hovatek.com/thread-439.html
Good to know it's fixed
Reply










Users browsing this thread:
1 Guest(s)