Hi, Guest! Login / Register
Giveaway: Free Hovatek T-shirts, Hoodies & Cufflinks.. I WANT ONE! (Nov 25, 2017)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

[Please help] bricked infinix x551

#1

Hi. I updated my infinix X551 from kitkat to lollipop using sp flash tools the procedure went on well and finished but the phone refuses to boot. When i connect to the pc, it is installed as a USB serial device..been charging for the past four days without any sign. Please help


Reply
#2
Hi. I updated my infinix X551 from kitkat to lollipop using spflash tools the procedure went on well and finished but the phone refuses to boot. When i connect to the pc, it is installed as a USB serial device..been charging for the past four days without any sign. Please help
Reply
#3
(10-23-2015, 08:10 AM)tsozungu Wrote: Hi. I updated my infinix X551 from kitkat to lollipop using spflash tools the procedure went on well and finished but the phone refuses to boot. When i connect to the pc, it is installed as a USB serial device..been charging for the past four days without any sign. Please help

Have you tried reflashing the kitkat ROM
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#4
Yes I have tried bt the computer recognizes the phone as USB Serial Device and not as preloader..therefore I cant flash the phone
Reply
#5
(10-23-2015, 02:18 PM)tsozungu Wrote: Yes I have tried bt the computer recognizes the phone as USB Serial Device and not as preloader..therefore I cant flash the phone

its similar to connection disconnection.
you need to update the VCOM drivers. see https://forum.hovatek.com/thread-439.html
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#6
I have followed the procedure step by step for the last 4days..I update the driver to Mediatek Preloader bt both sp flash tool and mtkdroid tools dont detect the phone even on a different PC
Reply
#7
(This post was last modified: 10-24-2015, 02:22 PM by hovatek. )
(10-23-2015, 07:28 PM)tsozungu Wrote: I have followed the procedure step by step for the last 4days..I update the driver to Mediatek Preloader bt both sp flash tool and mtkdroid tools dont detect the phone even on a different PC

Take out the battery using https://forum.hovatek.com/thread-7338.html then retry flashing
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#8
I took out the battery according to the tutorial bt the phone did not show any sign of charging.. when I try to connect it to the computer it was disconnecting and reconnecting even faster than before..is there any thing I could have done wrong?
Reply
#9
(10-25-2015, 07:09 PM)tsozungu Wrote: I took out the battery according to the tutorial bt the phone did not show any sign of charging.. when I try to connect it to the computer it was disconnecting and reconnecting even faster than before..is there any thing I could have done wrong?

No.
Launch Device Manager
What does the phone get detected as?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#10
My infinix x551 is finally up and running on Android 5.1 after a full week, thank you so much for your help and advice. I am much obliged.
Regards...
Reply










Users browsing this thread:
1 Guest(s)