Hi, Guest! Login / Register




Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

NEED HELP PLEASE

#1

Hello everyone, please I have a dead MEDIATEK chipset samsung s5 SM-g900H, completely dead all what i can do is enter the recovery mode ( volume up + power botton ), and when i turn it on just Samsung Galaxy S5 logo appears and then it turns off, and then the same message appears and it stays like that until i remove the battery to turn it of, please anyone can help me


Reply
#2
(11-01-2015, 11:27 AM)aimen86 Wrote: Hello everyone, please I have a dead MEDIATEK chipset samsung s5 SM-g900H, completely dead all what i can do is enter the recovery mode ( volume up + power botton ), and when i turn it on just Samsung Galaxy S5 logo appears and then it turns off, and then the same message appears and it stays like that until i remove the battery to turn it of, please anyone can help me

How did this start and have you downloaded the firmware?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#3
(11-01-2015, 06:13 PM)hovatek Wrote:
(11-01-2015, 11:27 AM)aimen86 Wrote: Hello everyone, please I have a dead MEDIATEK chipset samsung s5 SM-g900H, completely dead all what i can do is enter the recovery mode ( volume up + power botton ), and when i turn it on just Samsung Galaxy S5 logo appears and then it turns off, and then the same message appears and it stays like that until i remove the battery to turn it of, please anyone can help me

How did this start and have you downloaded the firmware?
the phone came to me like that, and after looking for some topics it seems i completely damaged the phone as i was trying to flash it with sp flash tool, and because the preoplder was disconnecting after every 2 seconds someone adviced me to go to format, and format the whole ...., and the phone after that doesn't work at all, no recovery mode nothing absolutely dead, just when i plug it with the pc it does a sound  unreconized device and that's it
Reply
#4
(This post was last modified: 11-02-2015, 02:20 PM by hovatek. )
(11-02-2015, 11:52 AM)aimen86 Wrote: the phone came to me like that, and after looking for some topics it seems i completely damaged the phone as i was trying to flash it with sp flash tool, and because the preoplder was disconnecting after every 2 seconds someone adviced me to go to format, and format the whole ...., and the phone after that doesn't work at all, no recovery mode nothing absolutely dead, just when i plug it with the pc it does a sound  unreconized device and that's it

Shouldn't be difficult to fix. Have you downloaded the firmware for the exact phone model? If not, whats the exact chipset of the phone i.e MT****
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#5
(11-02-2015, 02:19 PM)hovatek Wrote:
(11-02-2015, 11:52 AM)aimen86 Wrote: the phone came to me like that, and after looking for some topics it seems i completely damaged the phone as i was trying to flash it with sp flash tool, and because the preoplder was disconnecting after every 2 seconds someone adviced me to go to format, and format the whole ...., and the phone after that doesn't work at all, no recovery mode nothing absolutely dead, just when i plug it with the pc it does a sound  unreconized device and that's it

Shouldn't be difficult to fix. Have you downloaded the firmware for the exact phone model? If not, whats the exact chipset of the phone i.e MT****

sorry i don't know, there is any possibility how to find out what the exact MT chipset?

Reply
#6
(11-02-2015, 06:29 PM)aimen86 Wrote: sorry i don't know, there is any possibility how to find out what the exact MT chipset?

See http://www.needrom.com/download/11-s5-sm-g900-mt6592/
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#7
is it sure it's the right one?
Reply
#8
(This post was last modified: 11-03-2015, 01:40 PM by aimen86. )
it didn't work for me,
Reply
#9
(11-03-2015, 01:40 PM)aimen86 Wrote: it didn't work for me,

What error did you get?
Need further assistance? Speak with a Hovatek Representative:
Working Hours: Mondays - Saturdays ; 09:00 - 18:00 (GMT +1:00)
Reply
#10
Download STOCK Firmware and flash it using ODIN!
Reply










Users browsing this thread:
1 Guest(s)